Acknowledged Rewards from quests disappear

Ingame Nick: UltimateGR
Affected world(s): Sandbox16 (zz16)
Browser: Google Chrome
Reproduction steps:
  1. The quest was finished, so i went to take my reward
  2. I clicked to save the reward to the inventory ( I had space to the inventory).
  3. It said Invalid Error
Detailed error description (What you see):

I clicked to take the reward from the island quest but it said Invalid Error... I didnt get screenshot! Some players complain about this too!

How it should be:
Give the reward



Community Manager
Grepolis Team
This was related to the disappearing units bug and should not happen anymore.

Please feel free to update the thread otherwise.
Emmmm now this... I tried to do the same thing (put this on the invenotry) but....


Calydonian Boar
Yea i think it's not fixed just happend with me just now with a quest that increase stone production


Community Manager
Grepolis Team
What happens after getting that error? Does the quest disappear?

Yea i think it's not fixed just happend with me just now with a quest that increase stone production
I see you don't have any completed quest with the reward ready to be collected.


the same thing
I tried to put the reward in the inventory, but it was full. The message was normal : the inventory is full.
So I tried to use it in a city. The reward disappeared.


Community Manager
Grepolis Team
Thank you!

Did you also notice something in particular on these "broken" rewards? Or does it seem just random?


Calydonian Boar
On me it happend
It was a quest to sent recources (Reward Stone production)
I sent recources
Quest finish and is ready to accept
*I accept by mistake on a city that i already had the same bonus and was gonna end in 1hour and 25 min
It says reward is already active in this city than i try to store it in inventory and reward says already completed or used (can't remember now exatcly the message)
I refresh browser
Reward not in my intentory and not in any city and the one that already had the bonus was still at 1:25 to finish
Checked the quest reward not there


Divine Envoy
I also lost some slingers light ships and transport boats. Could you please fix it? thank you.


server time 16:52 [island]767746[/island] Island quest The Chariot tournament sent troops tried to save the bonus to inventory I took an error and units lost. I made cntrl F5 refresh units came but mission and bonus lost.