Fixed Problem with switching cities

Ingame Nick: DisturbedFan96
Affected world(s): ZZ12
Browser: Google Chrome

Detailed error description (What you see):
When I enter the game, I can switch cities fine, but after I farm the villages, this option does not work anymore.
When I press the arrow on my keypad, in the left upper corner it shows the next city, but in the game it does not change.
Another error occurs is when the city changes in the left corner (on google chrome bar), but the map does not move. I removed the option and then marked it again in the settings menu, but the bug remains. And I can not change to the next or previous city when I use the arrow next to the city name in Grepolis.
The 3rd problem happened when I try to switch from island view to city view, but it does not happen, the button looks like it has been pushed, but I do not get to see the city view.
Again, this happens only after I farm my villages, when I refresh the page it works fine.



Yeah, sometimes I can click the bandit camp, and sometimes I don't. This update wasn't very helpful and have a few bugs in the luggage.


Beta Team
Grepolis Team
Hello @DisturbedFan96,
I had a problem with reproducing this. Can you please tell me the exact steps? In my case I tried:
  1. Click on 'Farming villages' link
  2. Check 'Select all' in the Farming village window
  3. Change city using keyboard arrows
  4. Change city using the next city button
Did I miss something or did you do the same?
Yes, when I enter the farming village window (not using the Captain, I do not have Captain activated, just click on the village on the island) , and then try to click on the button, or use the keyboard arrows to the next or previous city, it does not change.


Beta Team
Grepolis Team
Great, I was able to reproduce it. :D
So I farmed a single village and when I tried to switch to the next city, I was not able to do so (Keyboard arrows work just fine, only the next city button is not). Switching from Island view to City view is not working as well. I will report it to devs so they can fix this issue as soon as possible. :)