Acknowledged Not letting assign a hero


Divine Envoy
When I try to assign a hero to my city , it says that alrewady 1 hero is on city .... But I have just conquered it and there are no heroes in .
Στιγμιότυπο οθόνης (16).png


Game support
It looks like the old player's hero is stuck assigned to the city and that's why you can't assign your own. We'll look into it


Divine Envoy
Ingame Nick: Mikevikiaris
Affected world(s):confused:ANDBOX 16
Reproduction steps:
  1. .
  2. .
  3. .
Detailed error description (What you see):When I try to assign the Hero PELOPS it will no tlet me . that happened AFTER I conquered the city and I don't know hwat happened ... I tried refreshing the site , even restarting the PC , but nothing happened .

How it should be:It should let me assign the hero to the city .

Στιγμιότυπο οθόνης (16).png

Sorry for any inconvenience :)


Divine Envoy
Sorry , Mikevik is my username . I woke up before so I got confused I am SO SORRY for any inconvenience :(


Divine Envoy
Is there anything that can be done ? Mikeik username , Temple ElementalEvil the town 554,512 the coordinates OC 55


I am Whitewiz1, the other half of this problem. My hero Christopholos is stranded. He was in the city that was conquered and now shows enroute to a ghost city. I am unsure how to display a screenshot to help out, but I cannot recruit any new heroes or recover him to assign him to a new city.
Ingame Nick: UltimateGR
Affected world(s): Sandbox16
Browser: Google Chrome
Reproduction steps:
1) I tried to assign one hero to a new city..
2)Then this appeared:

Last edited: