Fixed City foundation icon

morg

Manticore
Ingame Nick: *********
Affected world: zz7

(Bug found on desktop version)
Browser: Chrome + Firefox

Steps to reproduce:
send CS to found on a free anchor + wait
Weyyv7BzR-mBSsAYj1LSeQ.png


Detailed error description (What you see):
first everything seemed to be fine, but after night graphics activated the icon of colonization disappeared (missing on Firefox too).
fb7g0ncJT-eygcZ7ADWJ4w.png

How it should be:
City foundations should be displayed on the map with corresponding icons.
Z0s3iStYSEuqbIxMyj1qFA.png


are the night graphics supposed to look like this... ?! Well if yes, I'm sorry for the post, it took me long enough to realize what happened with my colonization... a more informative icon would be necessary, even if it wasn't a bug.
 
Last edited:

Arci

Community Manager
Grepolis Team
I'm gonna check if night bonus is supposed to have that icon as well.

A cache clean in the meantime would fit sure help :p
 

morg

Manticore
oye, I cleaned cache right away and double checked on other browser.
Although after taking another look I found a little brown sign there - a pirate poop or something like that - ... it might be the icon of colonization, I have no clue what the graphic design concept was, but for sure it tricked me for a couple of hours while I thought my colony ship will bounce due to another player spawned on same anchor or a bug like that.
When the colonization started the usual flag popped up (brown / night version) and the colonization ended successfully.

I'm unfamiliar with the night graphics, so shame on me.. not a bug, but this icon can be really confusing even on desktop version, there must be other ways for pirates to mark their territory...
 

Arci

Community Manager
Grepolis Team
That icon looks weird anyways. I think I'm going to do some other tests before archiving this report ;)

The missing/weird icon was displayed during the colo trip or after it landed (in night mode)?.
 

morg

Manticore
the icon problem occurred during the colo trip only in night mode, then I disabled night mode and the daytime icon was ok (the 2 posted screenshots were made within seconds)
I enlarged this fragment of the previous screenshot...
-OFl2pvwQMGhjIGhJO7b3A.png

after some editing you can see the pirate poop and another unidentified object in the sea:
DoBFlUgqTgCBIfSmhQBSHQ.png

after the colo landed the night and day icons were identical flags in different color (brown and yellow), both clearly visible unlike this icon above
 
Arci this might be similar to the villages overlapping icons issue we used to have some time ago on some specific island types....
 

Arci

Community Manager
Grepolis Team
The wrong icon is displayed, in fact the red rectangle does not cover it at all, but the "icon" continues on the right side.

I'll report it tomorrow, thanks for the participation!
 

DeletedUser4422

Guest
I have reported this to the Hungarian support almost a year ago and still nothing happened... sadly... #t10880203 (2016-10-02 00:33:10)

In that ticket I have clearly described the problem but the attachments got somehow deleted from the ticket since that. The problem can be easily fixed and it is caused by wrong background image in CSS for the night mode icon, it should be 'towns_sprite_night.png'
 

Arci

Community Manager
Grepolis Team
Unfortunately, especially in big projects like a game, it's not always that easy fix this kind of bugs, even if it may only seem just a wrong image on the database :(

And for sure this has less priority than for example trying to let the classic world playable :p
 

DeletedUser4422

Guest
I found the screenshots hope with this you can fix that in no time ;)
 

Attachments

  • Screenshot_856.png
    Screenshot_856.png
    276 KB · Views: 90
  • Screenshot_857.png
    Screenshot_857.png
    274.2 KB · Views: 80

DeletedUser4422

Guest
Unfortunately, especially in big projects like a game, it's not always that easy fix this kind of bugs, even if it may only seem just a wrong image on the database :(

And for sure this has less priority than for example trying to let the classic world playable :p
Of course as a webdev I understand that 100% but it is really frustrating having reported issues not fixed even after years :)
 
Top