Acknowledged CAPTCHA Error

Ingame Nick: galanoulis
Affected world(s): zz2
Browser: Chrome
Reproduction steps:
  1. .Try to make some cold trades to have the captcha menu appear.
  2. .
  3. .
Detailed error description (What you see):
As per normal tick the captcha box and wait.
After it keeps thinking the box is empty
Check again the captcha box and after a while (it "thinks"again) you get an error message saying (translated by Google)


Could not connect to the reCAPTCHA service.

Check your internet connection and reload to see a reCAPTCHA challenge.


and striaght afterwards teh red ribbon saying incorrect input

How it should be:
Captcha should be working....

Screenshot:


(keeps thinking far too much)



(message error is in greek due to browser settings but english translation was provided above)



 

Arci

Community Manager
Grepolis Team
I just tested it and the captcha works just fine for me. Is the issue still occurring?
 

S.G-1

Harpy
this is a problem of google and Your ISP , change IP and will be works again ;) i has this problem from some providers ( specially on free wifi)

however INNO should discovery in script that 3rd part service which is using in game
doesnt work correctly and make a bypass of this issue without captcha response
 

Arci

Community Manager
Grepolis Team
Thanks for the additional details :)

@galanoulis if you could reproduce the issue with the browser in english would be a huge help :)
Also copypasing the greek text would be nice :)
 
Last edited:

Arci

Community Manager
Grepolis Team
This seems to be a ReCaptcha issue, interacting with other scripts such as AdBlocker. Can you try again without any script active?
 
Also copypasing the greek text would be nice :)
Text in greek is the below

Δεν ήταν δυνατή η σύνδεση με την υπηρεσία reCAPTCHA.
Ελέγξτε τη σύνδεσή σας στο διαδίκτυο και επαναλάβετε τη φόρτωση, για να δείτε μια πρόκληση reCAPTCHA.



On my PC with Chrome I keep getting the very same error.
Adblock is deactivated for grepolis and also this occurs even with out the game scripts.

So to get the message in English I first tried with Edge (just in case) and it game me google image capcha where I had to select photos

Therefore to get the message in english I tried from a virtual machine with chrome on my PC and got again the google captcha to select images (screenshot below)



which worked.


So it is definitely not and ISP or external IP issue as @S.G-1 said (at least on my case)

What I do not understand is why on my PC I get the error with chrome while on the VM I get the photos captcha. Only difference on the installations is the OS language which should not affect apart from messages language.
 

S.G-1

Harpy
@galanoulis i facing this issue with captcha many times if i collecting from hundrets of seas a gold from market on few serwers in short time ( reset of market has made on 4 servers in this same time ) re-captcha dont work correctly after 20-30 times google discovery that i'm BOT ;) and blocking re-captcha for few minutes ... only reconnect ( if You have dynamic IP ) solving this problem .. or waiting a minimum 1h
also many times even if Your response was correctly You continuue picture re-captcha 4 times per one gold exchange .

and as said @Arci this is issue of captcha and "anti bot" system discovery ... multiple answers from one IP from one pc activating a trigger on captcha system and blocking using it ..

and as I said previously : INNO should discovery this !!! and allow to overpass if captcha is blockedand we are unable to complete this action.
using any 3rd party of programs which You dont have control should have bypass to allow work Your game correctly ...
 
Last edited: